VideoCAD

Первый проект с VideoCAD, шаг за шагом

Hide Navigation Pane

Первый проект с VideoCAD, шаг за шагом

Previous topic Next topic No directory for this topic Expand/collapse all hidden text  

Первый проект с VideoCAD, шаг за шагом

Previous topic Next topic Topic directory requires JavaScript JavaScript is required for expanding text JavaScript is required for the print function Mail us feedback on this topic!  

Задача

 

Допустим, у  вас имеется планировка объекта видеонаблюдения в любом из форматов: *.bmp, *.png, *.jpg, *.gif, *.tif, *.emf, *.wmf, *.dxf, *.dwg, *.pdf.

На планировке известны места интереса, за которыми надо наблюдать.

Необходимо подобрать оптимальное размещение и параметры камер.

 

 

Решение

 

 

Если это ваш первый проект с VideoCAD, порядок решения задачи может состоять из следующих шагов:

 

       Краткое знакомство с интерфейсом

 

 

Главное окно VideoCAD называется Графическое окно.  Вверху окна находится Главное меню и Панель инструментов.

 

Кнопками из нижнего ряда Панели инструментов вызываются инструменты рисования и редактирования, а кнопками из верхнего ряда вызываются дополнительные окна.

 

В центре Графического окна находится Область отображения с 2D проекцией плана на котором вы будете рисовать и размещать камеры.

 

Во время рисования или редактирования построений под Областью отображения появляется Панель параметров текущего построения. На панели можно менять параметры построения, которое вы рисуете или редактируете.  Когда рисования или редактирования не происходит, Панель параметров текущего построения скрывается.

Если на плане выделено более одного объекта, то появляется Панель редактирования выделенного, на которой можно редактировать параметры всех выделенных объектов сразу.

Кликните чтобы развернуть
Кликните чтобы развернуть

 

Перемещаться по плану удобно с помощью мыши с колесиком. Двигать план можно мышью с нажатым колесиком, масштабировать план - поворотом колесика.

 

Нажатая Ctrl уменьшает шаг масштабирования.

 

Последовательность Нажать правую кнопку мыши > Двигать мышь > Отпустить правую кнопку формирует черную рамку увеличения.

 

Если мышью пользоваться неудобно, смотрите кнопки на Панели инструментов Двигать Увеличить и Уменьшить

 

Начальный режим, из которого начинаются все действия, называется Выделить/редактировать. Перейти в начальный режим можно кликом по кнопке в левой части нижнего ряда Панели инструментов или нажав на клавиатуре Esc.

 

Для получения справки по любому окну или элементу интерфейса кликните по нему (если кликнуть нельзя -  установите на нём курсор мыши) и нажмите клавишу F1.

Для получения справки по кнопке кликните по ней правой кнопкой мыши, а затем левой кнопкой по появившемуся пункту Назначение кнопки.

 

Подробнее см. Графическое окно, Область отображения, Панель параметров текущего построения, Панель редактирования выделенного, Информационная панель

 

       Загрузка планировки

 

1. Выберите пункт Главного меню Чертёж>Загрузить подложку> В горизонтальной проекции.

 

2. В появившемся диалоге выберите файл планировки и кликните по кнопке Открыть. Планировка появится в окне.

 

3. В появившемся диалоге Настройка подложки кликните по кнопке Рулетка.

 

4. Двумя кликами по планировке отметьте 2 точки, расстояние между которыми вам известно (например, длина стены).

 

5. Введите в окошко Реальное расстояние известное вам расстояние между точками (длину стены).

 

6. Кликните ОК в диалоге Настройка подложки. Планировка будет отмасштабирована таким образом, что отмеченное кликами расстояние на планировке станет равным введенному в окошко реальному расстоянию.

 

После изменения размера планировка может потеряться с экрана - найдите её с помощью мыши.

 

Вид окна Настройка подложки и доступные инструменты зависят от формата файла подложки.

Если формат файла подложки - PDF, то в диалоге настройки подложки вы можете выбрать страницу документа и разрешение.

Если формат подложки - AutoCAD DXF или DWG, то вы можете выбрать лист документа, настроить видимость слоев документа и другие параметры.

 

Для замены, настройки, перемещения, скрытия, удаления подложки после её размещения используйте пункты в ветви Главного меню Чертеж.

 

 

Вы можете быстро превратить в подложку картинку с экрана из любой графической программы, карт Google, OSM, Yandex:

1. Разверните окно программы с картой местности на экране. Для вывода а полный экран карты из интернет браузера нажмите F11 на клавиатуре.

2. Нажмите на клавиатуре Print Screen (или Alt + Print Screen).

3. Откройте VideoCAD и выберите Меню>Чертёж>Вставить подложку из буфера обмена.

4. Кликните кнопку Обрезать подложку в диалоге Настройка подложки и вырежте рамкой только нужную часть карты. Далее отмасштабируйте подложку как описано выше.

 

Этот простой метод импорта карт подходит для любых программ, позволяет получить подложку размером в несколько мониторов и не зависит от сторонних сервисов.

 

 

       Моделирование обстановки

 

Рисование построений

 

Поверх планировки, вокруг мест интереса, за которыми надо наблюдать, обведите элементы строений на плане с помощью построений. Кнопки выбора построений находятся в середине нижнего ряда Панели инструментов.

Обведите стены, колонны и плиты с помощью инструментов Стена и Прямоугольник .  Рисование построения выполняется двумя кликами по плану.

 

Для рисования стен, в которых потребуется прорезать проемы или врезать окна или двери используйте только инструмент Стена.

Задавайте толщину и переключайте ориентацию стены прямо во время её рисования .

 

 

 

 

Задавайте параметры построений на Панели параметров текущего построения, которая будет появляться в нижней части окна.

 

Важно задать минимальную и максимальную высоты построения. Вместо максимальной высоты можно ввести собственную высоту построения , как вам удобнее.

 

Построения рисуются на плане в виде 2D фигур, но в 3D они вытягиваются по высоте от минимальной до максимальной высоты, образуя трехмерные объекты.

 

На Панели параметров текущего построения можно задать координаты крайних точек построений, размеры, материал , цвета в 2D, 3D и при печати .

 

Построению - Стене можно задавать ориентацию и толщину .

 

Состав параметров, выводимых на Панель параметров текущего построения зависит от типа построения, которое вы рисуете.

 

Для отмены / повторения последнего действия используйте кнопки справа в нижнем ряду Панели инструментов или Ctrl+Z, Ctrl+Y

Для построения цилиндрических поверхностей используйте Окружность и Дуга.

Для построения лестниц используйте Лестница

Для построения вертикальных прямоугольных плоскостей и для измерения расстояний используйте Отрезок.  Для измерения углов используйте Угол .

Для рисования в 3D табличек или любых других растровых картинок используйте 3D изображение.

Для построения наклонных, полупрозрачных и сложных поверхностей используйте Наклонный прямоугольник.

 

Теоретически, набором наклонных прямоугольников можно нарисовать что угодно, хотя это может быть не просто.

 

Чтобы создать наклонные объекты вы можете превратить вертикальные построения в 3D модель. 3D модели можно наклонять и трансформировать.

 

Для построения плоских объектов сложной формы используйте инструмент Полигон.

 

Более сложные объекты могут быть смоделированы в SketchUP и импортированы в VideoCAD.

 

Редактирование построений

 

 

Последовательность Клик левой кнопкой мыши > Движение мыши > Второй клик левой кнопкой формирует малиновую рамку выделения. Все построения попадающие в рамку будут выделены.

 

Нажатый Shift во время выделения приводит к выделению частично попадающих в рамку объектов.

 

Выделять построения можно и по одному, кликая по их линиям левой кнопкой мыши.

 

Нажатая Ctrl меняет логику выделения.

 

Выделенные построения можно Вырезать Копировать Вставить Переместить Повернуть Масштабировать Отразить Отфильтровать пользуясь кнопками слева в нижнем ряду Панели инструментов.

 

 

 

Чтобы слить контуры пересекающихся построений: выделите построения и выберите пункт в Главном меню > Редактировать >Слить контур.

 

 

Для редактирования одного построения - кликните по любой линии построения. После чего можно менять параметры построения на появившейся Панели параметров текущего построения и двигая малиновые метки на плане.

 

Нажатая Ctrl меняет результат движения меток.

 

Чтобы редактировать только что нарисованное построение кликните на Панели параметров текущего построения.

 

 

Если выделено более одного построения, то появляется Панель редактирования выделенного. На панели можно редактировать параметры сразу всех выделенных построений  Перед редактированием можно Отфильтровать построения по разнообразным признакам.

 

       Взгляд в 3D

 

Чтобы увидеть ваши построения в 3D откройте окно 3D Мир кнопкой в правой части верхнего ряда Панели инструментов.

 

В окне 3D Мир можно перемещаться в 3D пространстве с помощью мыши с колесиком.

 

Движение мыши при нажатой левой кнопке – вращение плана вокруг оси проходящей через его центр.
Движение мыши при нажатой правой кнопке – изменение направления "взгляда".
Движение мыши при нажатом колесике – сдвиг плана.
Вращение колесика  – приближение или удаление от предмета находящегося под курсором.

 

Если вы потерялись в 3D мире, кликните по кнопке в левом верхнем углу окна или откройте Панель инструментов окна 3D Мир, кликнув по кнопке в левом верхнем углу окна, кликайте по кнопкам на вкладке Навиг. (Навигация) панели инструментов окна 3D Мир.

Чтобы вид в окне 3D Мир не менялся при добавлении новых построений - разместите 4 любые построения по углам вашей "стройплощадки" - отметьте её границы.

 

Для наблюдения в 3D вы также можете открыть окно 3D Видео в правой части верхнего ряда Панели инструментов и направить камеру, размещенную на плане, на место вашего строительства. Управление камерой мы рассмотрим ниже.

 

       Врезание окон и дверей, размещение 3D моделей

 

 

Чтобы врезать в стену окно или дверь кликните кнопку 3D модель в центральной части нижнего  ряда Панели инструментов,  выберите в выпадающем меню ветку WINDOWS (окна) или DOORS(двери) и выберите 3D модель окна или двери в ветке.

 

Отметьте кликом место размещения 3D модели прямо поверх стены.

 

Вырезать проём в стене заранее не нужно, 3D модель двери или окна вырежет проём для себя сама если в параметрах 3D модели отмечен чекбокс Проём в стене.

 

На Панели параметров текущего построения задайте высоту 3D модели над землей одним параметром .

 

В соседних слева окошках ANG, X, Y, H вы можете изменить угол поворота и размеры 3D модели отдельно по осях X, Y, и Z .

Если чекбокс слева от значка цепи отмечен, то при изменении одного из размеров будут меняться и остальные размеры чтобы пропорции 3D модели сохранились.

 

Если во время размещения 3D модели удерживать Ctrl, то 3D модель размещается повернутой на  90 градусов. Если удерживать Shift, то 3D модель размещается повернутой на 180 градусов. Если удерживать Ctrl+Shift, то 3D модель размещается повернутой на 270 градусов.

 

При необходимости сразу после размещения разверните или растяните 3D модель с помощью малиновых меток. Можно также сдвинуть только что размещённую 3D модель мышью и менять параметры на Панели параметров текущего построения.

 

Чтобы вырезать пустой проем в стене откройте инструмент Проём в стене в центральной части нижнего ряда Панели инструментов и нарисуйте проекцию проема прямо поверх стены.

 

Высоты проема задавайте на Панели параметров текущего построения уже знакомыми параметрами . В 3D проем будет простираться по высоте от минимальной до максимальной высоты.

 

Проемы могут быть не прямоугольными, могут пересекаться, располагаться друг над другом.

 

 

 

       Использование 3D моделей

 

 

На предыдущем шаге мы уже научились размещать 3D модели в качестве окон и дверей. Но 3D модели - это не только окна и двери. 3D моделями могут быть любые предметы, люди, животные,  растения, транспортные средства, строения, целые здания, внутри которых можно размещать камеры.

Выбрать 3D модель вы можете через кнопку 3D модель в центральной части нижнего ряда Панели инструментов.

 

Также как и построения, 3D модели можно выделять рамкой или кликом. Выделенные 3D модели можно Вырезать Копировать Вставить Переместить Повернуть, Отфильтровать .

 

Также как и построения, 3D модель можно переводить в состояние редактирования двойным кликом, после чего менять её параметры на появившейся Панели параметров текущего построения.

 

Библиотеку 3D моделей можно пополнять, можно редактировать 3D модели в библиотеке (менять размеры и цвета, отражать, менять точку установки номера). Для редактирования 3D моделей есть специальное окно Окно 3D Модели, вызвать которое можно из Главного меню, 3D Модели>Окно 3D Модели  или кнопкой  на Панели параметров текущего построения.

Кликните чтобы развернуть
Кликните чтобы развернуть

 

 

Рекомендуется избегать перегрузки проекта деталями, не имеющими влияния на проектные решения, но требующими ресурсов для перерисовок. Для красивых картинок вы сможете добавить детали при окончательном оформлении проекта. Для комфортной работы со сложными планами рекомендуется переместить лишние детали на отдельные слои, которые вы сможете включать и выключать. Смотрите подробнее: Быстродействие и системные требования.

 

       Окно 3D Видео

 

Откройте окно 3D Видео кнопкой в правой части верхнего ряда Панели инструментов.

 

В окне вы увидите трехмерную модель картинки от камеры.

 

На картинке будет то, на что направлена единственная камера на плане.

 

 

Если двигать курсор мыши над окном 3D Видео с нажатой левой кнопкой мыши, то камера будет менять направление вслед за курсором.

 

 

       Окно Геометрия камеры

 

Откройте окно Геометрия камеры кнопкой в центральной части верхнего ряда Панели инструментов.

 

1. Прежде всего установите Размер видеосенсора, Разрешение в пикселях (Активн. пикселей) и Формат кадра. Значения этих параметров вы можете найти в спецификации камеры.

 

 

2. Фокусное расстояние объектива и Высоту установки камеры установите предварительно. В процессе  проектирования вы сможете подобрать объектив и оптимальную высоту установки.

 

 

3. Задайте Высоту верхней  границы зоны обзора равной максимальной высоте целей, которые вы хотите наблюдать.

 

Задайте Высоту нижней границы зоны обзора равной минимальной высоте которую вы хотите наблюдать.

 

 

 

 

 

 

 

Проекция зоны обзора на плане строится из условия попадания в кадр пространства от нижней до верхней границ зоны обзора.

 

 

       Плотность пикселей

 

Откройте окно Плотность пикселей кнопкой в центральной части верхнего ряда Панели инструментов.

 

В окне вы увидите таблицу, в строках которой показано соответствие:

 

цвета регионов зоны обзора камеры на плане;
названия критериев которым удовлетворяют окрашенные регионы (мониторинг, обнаружение, опознавание и т.д.);
значения плотности пикселей (пиксель/метр) на дальних границах регионов;
картинки с ожидаемой плотностью пикселей на дальних границах регионов каждого цвета (Разрешение);
картинки, демонстрирующие какую часть кадра будет занимать группа людей  на дальних границах регионов каждого цвета (Поле зрения).

 

 

Контекстное меню картинок позволяет выбрать другие картинки или установить собственные картинки.

В окне Плотность пикселей можно выбрать другие рекомендации (наборы критериев) и настроить собственные критерии. Можно назначать разным камерам в проекте разные наборы критериев.

 

Если двигать курсор мыши над картинками, то увеличенная картинка под курсором появится вверху окна. Клик по картинке открывает таблицу тестовых картинок.

 

Сопоставляя цвета на раскрашенной зоне обзора на плане и в таблице, вы можете оценивать плотность пикселей камеры в каждой точке на плане. По картинкам в таблице вы можете оценивать с каким разрешением может отображаться человек и автомобильный номер и какую часть кадра они могут занимать в каждой точке зоны обзора.

 

       Выбор положения и параметров камеры

 

Перемещение камеры:

 

выделите камеру кликом по объективу или по значку;
поместите курсор над объективом выделенной камеры и нажмите левую кнопку мыши;
не отпуская кнопку мыши, перемещайте выделенную камеру на новое место;
отпустите кнопку мыши.

 

 

Поворот камеры:

 

кликните по розовой метке в середине верхней границы зоны обзора;
переместите курсор на новое место;
кликните повторно;

 

Обратите внимание - надо делать 2 клика.

 

Выделять камеры можно также как и построения: рамкой выделения или кликом. Для перемещения и поворота выделенных камер удобно использовать кнопки Переместить Повернуть слева в нижнем ряду Панели инструментов или контекстное меню.

 

Изменение высоты установки камеры

 

Изменять высоту установки удобно выбором значения из списка в окне Геометрия камеры .

 

 

 

Изменение фокусного расстояния объектива:

 

кликните по любой из оранжевых меток на краях верхней границы зоны обзора;
переместите курсор на новое место;
кликните повторно;

 

.

Текущее значение фокусного расстояния можно наблюдать и менять в окошках Фокусное расстояние в середине верхнего ряда Панели инструментов. и в окне Геометрия камеры

 

Изменение разрешения камеры в пикселях:

 

Изменять разрешения камеры в пикселях удобно выбором значений из списков в окне Геометрия камеры .

 

Перемещая и поворачивая камеру на плане, выбирайте оптимальное место установки.  Если камеру можно устанавливать на разной высоте, - изменяйте высоту установки камеры в окне Геометрия камеры.

 

При возможности выбора объектива, - изменяйте фокусное расстояние объектива, перемещая метки на углах зоны обзора или выбором значений в окошках.

 

При возможности выбора модели камеры, - изменяйте разрешение в пикселях в окне Геометрия камеры.

 

Следите за моделью картинки от камеры в окне 3D Видео.

 

Следите за покрытием планировки цветными регионами. Смотрите соответствие цвета региона и разрешения в таблице в окне Плотность пикселей.

 

Добивайтесь оптимального размещения камеры, чтобы места интереса на плане были покрыты регионами с цветом, соответствующим требуемой плотности пикселей, а в окне 3D Видео были видны цели наблюдения.

 

Если плотность пикселей в точке интереса недостаточно, то вы можете его увеличить несколькими способами:

 

 

Приблизить камеру к точке интереса

 

Плюсом такого решения является уменьшение подверженности камеры затенениям от случайных препятствий.

Нежелательным эффектом будет сужение поля зрения вблизи точки интереса.  Также может быть технически невозможно закрепить камеру ближе или провести к ней кабель.

 

При приближении камеры к цели большую роль начинает играть высота установки камеры.

 

 

Уменьшить высоту установки

 

Снижение высоты установки не только приближает камеру к точке интереса, но и делает ракурс, под которым лица попадают в кадр более выгодным для распознавания.

Нежелательными эффектами являются

снижение вандалозащищенности камеры и

увеличение подверженности затенениям от случайных препятствий.

 

Чем меньше расстояние от камеры, там большее влияние имеет высота установки.

 

 

Увеличить фокусное расстояние объектива

 

Это приведет к увеличению плотности пикселей на заданном расстоянии от камеры, но и к сужению поля зрения.

 

Плюсы этого решения против приближения камеры к точке интереса -  это свобода в выборе места установки камеры и хорошая вандалозащищенность.

Минус - увеличенная подверженность затенениям от препятствий.

 

 

Увеличить разрешение камеры в пикселях

 

Плотность пикселей увеличится без изменения размеров зоны обзора. Но выбор камеры с большим разрешением приведет к удорожанию проекта. Кроме того, камеры высокого разрешения, как правило, обладают худшей светочувствительностью или снижают своё разрешение при недостатке света.

 

 

Таким образом, выбор положения и параметров камеры - это задача с большим количеством переменных. VideoCAD призван помогать решать такие задачи.

 

Обратите внимание, что фрагмент области интереса, ограниченный желтой рамкой, показан в зеленой рамке с реальном разрешении камеры. Так работает инструмент PiP (картинка в картинке).

Чтобы включить PiP, включите обработку изображения в Главном меню окна 3D Видео, Быстродействие>Отключить обработку изображения.

Указывайте место для желтой рамки кликом средней кнопкой мыши (колесиком) по картинке.

Чтобы изменить опции режима PiP, кликните по картинке правой кнопкой мыши и перейдите на вкладку PiP в появившейся Панели параметров изображения.

 

См. подробнее PiP

 

       Много камер в проекте

 

Чтобы создать копию настроенной камеры:

 

выделите камеру кликом по её объективу;

 

cкопируйте и вставьте камеру с помощью кнопок в левой части нижнего ряда Панели инструментов Копировать Вставить или Ctrl+C > Ctrl+V.

 

Для копирования можно просто сдвинуть камеру с нажатой левой кнопкой мыши и клавишей Ctrl.

 

 

Чтобы создать новую камеру с параметрами по умолчанию, воспользуйтесь кнопкой Создать камеру  в верхнем ряду слева на Панели инструментов.

 

Параметры в диалоге можно оставить без изменения.

 

 

Выделять, копировать и вставлять можно по несколько камер одновременно, можно делать это вместе с построениями и 3D моделями.

 

 

 

 

 

Активная камера

 

Камера, которой можно управлять, называется активной камерой.

 

Параметры активной камеры доступны в окнах программы.

 

Значок активной камеры выделяется красным.

 

 

Чтобы активировать любую камеру:

 

кликните по ней двойным кликом;
или выберите её название в списке Активная камера в левой части верхнего ряда Панели инструментов.

 

 

 

Размещайте и настраивайте новые камеры на плане также как и первую камеру.

 

       Вид зоны обзора и затенения от препятствий

Группа кнопок в левой части верхнего ряда Панели инструментов управляет видом проекции зоны обзора активной камеры на плане и в 3D. Комбинаций кнопок с учетом выпадающих меню довольно много. Вы можете почитать о них позже и попробовать как они работают. На первом этапе освоения программы оставьте кнопки в положениях по умолчанию.

 

Если есть выделенные камеры, то эти кнопки подкрашиваются малиновым и управляют сразу всеми выделенными камерами.

 

Кнопка Затенения управляет расчетом затенений зоны обзора активной камеры от окружающих предметов.

 

 

Чтобы включить расчет затенений выберите В пределах проекции в выпадающем меню. Чтобы выключить расчет затенений для активной камеры выберите Выкл.

 

 

Автоматический расчёт затенений осуществляется только для активной камеры. Для остальных камер затенения отображаются из памяти. Если необходимо пересчитать затенения для определённой камеры - активируйте её. Чтобы пересчитать затенения для всех выделенных камер, кликните Главное меню>Вид>Пересчитать затенения.

 

В случае большого количества затеняющих объектов, расчет затенений становится сложной ресурсоемкой операцией. Не рекомендуется держать расчет затенений постоянно включенным.

 

Для отключения автоматического расчёта затенений (с сохранением уже рассчитанных затенений) снимите отметку с пункта Главное меню>Вид>Считать затенения активной камеры.

 

Во время расчёта затенений на кнопке Затенения мигает красная рамка .

 

Подробнее см. Затенения, Быстродействие и системные требования

 

       Модели камер

 

Вместо ввода параметров камер по отдельности из спецификации, вы можете выбрать модель камеры из Таблицы моделей камер.

Открыть Таблицу моделей камер можно кнопкой  в центре верхнего ряда Панели инструментов.

 

 

В окне Таблица моделей камер имеется 2 вкладки:

 

Все модели - все модели камер, имеющиеся в базе данных;
Используемые модели - модели уже используемые в текущем проекте.

 

Для выбора ранее не используемой модели камеры переключайтесь на вкладку Все модели. Переключатель вкладок находится в левом верхнем углу окна Таблица моделей камер.

 

 

Вы можете выбрать модель камеры согласно необходимым критериям.

Для этого откройте Фильтр моделей камер кнопкой на Панели инструментов.

Вы можете задать часть имени модели, тип камеры, размер сенсора, диапазоны разрешения, фокусного расстояния объектива, горизонтального угла обзора, максимальной дальности ИК подсветки, цены.  Можно выбрать особенность камер, форму корпуса, защиту от окружающей среды, напряжение питания, производителя и поставщика.

 

Кликните чтобы развернуть
Кликните чтобы развернуть

 

Также Вы также можете воспользоваться фильтрами в верхней части столбцов между ячейками таблицы и заголовками.

 

Можно фильтровать модели по любой комбинации параметров.

 

 

Набор видимых параметров в таблице гибко настраивается. Попробуйте выбирать предопределенные наборы параметров в списке на панели Виды в нижней части таблицы.

 

 

 

Short - короткий набор параметров для выбора модели.
Normal - набор основных параметров из спецификаций камер.
Extended - расширенный набор параметров.

 

Управлять видимостью отдельных столбцов можно через меню в левом верхнем углу Таблицы.

 

Чтобы показать параметры модели компактно, в виде карточки, кликните по кнопке Карточка модели камеры.

 

 

База моделей камер регулярно пополняется новыми моделями. Загрузить обновления базы моделей камер c сайта cctvcad.com в локальную базу моделей на компьютере можно с помощью кнопки Download (базы моделей на cctvcad.com) на панели инструментов вкладки Все модели Таблицы моделей камер или с помощью пункта Базы моделей камер на cctvcad.com Главного меню Графического окна.

Чтобы назначить модель активной камере выберите кликом строку с нужной моделью и кликните по кнопке в левом нижнем углу окна.

 

Назначить модель активной камере можно и без Таблицы моделей камер, выбрав название модели в списке Модель активной камеры в центре верхнего ряда Панели инструментов Графического окна. По умолчанию в списке отображаются только используемые в проекте модели. Чтобы показать все модели выберите ПОКАЗАТЬ ВСЕ МОДЕЛИ.

 

Чтобы отфильтровать модели камер по вашим критериям откройте Фильтр моделей камер кнопкой на Панели инструментов.

 

Вы можете добавить ваши собственные модели камер в базу моделей.

 

Подробнее смотрите: Базы параметров моделей камер, Таблицы моделей камер, Модель активной камеры, Фильтр моделей камер, Карточка модели камеры

 

       Окно Мониторов

 

Откройте Окно мониторов кнопкой в правой части верхнего ряда Панели инструментов.

 

Выделите на плане камеры, которые вы хотите показать на мониторе.

 

Выделять камеры можно также как и построения: рамкой выделения или кликом по объективу. Чтобы выделить все камеры - нажмите Ctrl+A.

 

Кликните по левой верхней ячейке Окна мониторов. Появится окно 3D Видео, в котором будут генерироваться картинки от выделенных камер и загружаться на монитор. Дождитесь окончания процесса.

 

Выберите в Окне мониторов: Главное меню>Изображение>Экспорт в *.html и сохраните монитор в html файл.

 

Кликните по ячейке html файла, открытого в браузере.

 

Подробнее смотрите: Окно мониторов, Смотрите пример монитора (размер файла 4 Мб).

 

       Калькулятор полосы пропускания и дискового пространства

 

VideoCAD имеет интегрированный калькулятор требуемой полосы пропускания и дискового пространства – профессиональный инструмент расчёта сетевого трафика, создаваемого IP видеокамерами (видеосерверами) и необходимого дискового пространства для хранения видеоархива.

 

С помощью калькулятора вы сможете:

 

Раcсчитать сетевой трафик, генерируемый IP видеокамерами и видеосерверами для грамотного проектирования сетей видеонаблюдения.

 

Расcчитать требуемое дисковое пространство для хранения видеоархива в течении заданного времени.

 

См. подробнее: Калькулятор полосы пропускания и дискового пространства

 

       Выходные файлы и документы

 

2D чертеж размещения камер

 

Чтобы сохранить полученное размещение камер в графический файл воспользуйтесь пунктом Главного меню: Чертеж>Сохранить как. Вы можете сохранить чертеж в форматы AutoCAD (*.dxf, *.dwg) и в другие растровые и векторные форматы. Разрешение файла может превышать разрешение экрана.  Сохранение в разные форматы имеет свои ограничения.

 

Перед сохранением вам будет предложено изменить параметры экспорта. На первом этапе освоения программы можно оставить параметры без изменений. Возможность настройки экспорта вам пригодится, когда вы захотите что-нибудь изменить в выходном файле.

 

 

См. подробнее: Сохранить как

 

3D файл COLLADA (*.dae)

 

Результаты 3D моделирования VideoCAD можно экспортировать в файл открытого 3D формата COLLADA. Файлы COLLADA могут быть импортированы в множество 3D редакторов, включая SketchUP, и конвертированы ими в другие 3D форматы. См. подробнее о формате COLLADA https://en.wikipedia.org/wiki/COLLADA https://ru.wikipedia.org/wiki/COLLADA

 

Экспорт выполняется очень просто:

1. Выделите то что нужно экспортировать на плане в Графическом окне (2D).

2. Выберите Главное меню>3D Модели>Экспорт в 3D файл COLLADA.

 

При экспорте сложных 3D моделей 3D файл COLLADA может получиться довольно большим и экспорт потребует много времени. Попробуйте сначала выделить и экспортировать одну камеру и несколько построений.

 

VideoCAD поддерживает также импорт файлов COLLADA. Можно импортировать 3D планировку, например созданную в SketchUP, из файла COLLADA, разместить камеры и экспортировать результат проектирования с трёхмерными зонами обзора камер обратно в SketchUP.

 

 

Чертеж плана в 3D

 

Вы можете сохранить картинки из окна 3D Мир во множество форматов. Разрешение полученных картинок может превышать разрешение экрана Windows.

 

 

См. подробнее: Save and Print

 

Картинки от камер

 

Вы можете получить как обычные 3D изображения, так и картинки с учетом реальных параметров камер и сцены в разных комбинациях (реальное разрешение камеры и объектива, экспозиция и скорости целей, чувствительность и освещенность, глубина резкости, дисторсия объектива и др.), можете получить картинки с реальным разрешением в десятки мегапикселей, статичные и анимированные, отдельные и объединенные в мониторы.

 

Для точного моделирования параметров камер необходимо понимание их устройства. Однако для получения обычных 3D изображений специальных знаний не требуется.

 

 

См. подробнее: 3D Видео, Окно Мониторов, Примеры работы с VideoCAD

 

Таблица камер

 

Чтобы получить информацию из проекта в табличном виде воспользуйтесь кнопкой Таблица камер в левой части верхнего ряда Панели инструментов.

 

Интерфейс Таблицы камер похож на интерфейс Таблицы моделей камер. Вы также можете выбирать Виды, фильтровать камеры, искать параметры, выбирать столбцы для отображения и т. п.

 

С помощью Таблицы камер можно получить разнообразные табличные отчеты, которые можно экспортировать в форматы *.txt,*.csv (разделитель можно менять),*.htm,*.rtf,*.xls,*.xlsx,*.xml  или просто скопировать в Excel.

 

выделите мышью произвольную группу ячеек в таблице;
правым кликом откройте контекстное меню и выберите Копировать выделенное;
откройте Excel и вставьте фрагмент.

 

Чтобы экспортировать всю таблицу в файл кликните по кнопке на панели Таблица в левом нижнем углу окна и выберите формат файла для экспорта.

См. подробнее: Таблица камер

 

Отчет в PDF

 

Чтобы получить отчет в формате PDF, включающий тексты, таблицы и картинки проекта,  воспользуйтесь пунктом Главного меню: Проект>Отчет в PDF.

На первом этапе освоения программы вы можете не менять никаких параметров отчета, просто кликните по кнопке в левом нижнем углу окна PDF отчета.  Возможность гибкой настройки отчета вам пригодится, когда вы захотите внести изменения в отчет.

 

Во время подготовки отчета будут открываться окна, меняться картинки. Пожалуйста дождитесь окончания процесса.

 

На следующем этапе освоения VideoCAD попробуйте выбирать готовые шаблоны в окошке Шаблон отчета в правом нижнем углу окна.

 

Смотрите примеры отчетов:

 

 

Чтобы увидеть реальное разрешение камер, увеличивайте картинки от камер в Acrobat Reader. Особенно интересны Camera 3 и Camera 4.

 

 

См. подробнее: Отчет в PDF, Получение отчёта в формате PDF

 

Другие выходные документы

 

 

 

 

 

 

 

 

 

Печать из VideoCAD

 

чертежа размещения камер с возможностью наложения штампа, печать на несколько страниц под склейку;

 

 

 

 

 

 

 

 

 

 

       Дополнительные возможности

 

VideoCAD предлагает инструменты, упрощающие и ускоряющие работу со сложными проектами, а также позволяющие решать задачи, выходящие за рамки учебного примера.

 

3D Тест и 3D Тест на границах зоны обзора

 

3D Тест позволяет быстро оценить как может выглядеть любая 3D модель из библиотеки VideoCAD в любой точке пространства через активную камеру.

 

 

Вы можете выбрать любую 3D модель из библиотеки или прямо на плане, указать кликом её расположение на плане и оценить как она будет выглядеть. На Панели параметров текущего построения можно изменить размеры 3D модели и её высоту над землёй. Можно поворачивать и масштабировать тестовую модель мышью в окне 3D Тест чтобы внимательно её рассмотреть.

 

См. подробнее: 3D Тест

 

Типы линий

 

Вместо задания параметров для каждого построения отдельно, можно выбирать заранее настроенные типы линий для построений, камер, 3D моделей и кабелей. В типе линии содержится информация о стиле, толщине, цвете линии отдельно в 2D, 3D и при печати, предустановленные высоты для построений и 3D моделей, отметки является ли тип линии кабелем и должны ли построения этим типом линии считаться препятствиями при расчете затенений.

 

См. подробнее: Типы линий

 

Шрифты

 

Для текстовых надписей, названий и титров используются настраиваемые шрифты. В параметры шрифта входят: название, стиль, цвет, размер, отметка является ли шрифт масштабируемым.

 

См. подробнее: Шрифты

 

Привязки

 

Во время черчения курсор мыши притягивается к точкам, линиям и направлениям. Настройки привязок можно оперативно менять во время работы на панели привязок, которую можно открыть кнопкой Глобальные привязки в правой части нижнего ряда Панели инструментов.

 

См. подробнее: Привязки

 

Вертикальная проекция плана

 

При необходимости можно открыть вертикальную проекцию плана, отжав кнопку Скрыть вертикальную проекцию. В вертикальной проекции также можно размещать построения, 3D модели и кабели.

Чтобы двигать горизонтальную проекцию относительно вертикальной проекции - двигайте мышь при нажатой средней кнопке (колесике),  удерживая Ctrl.

Для изучения зоны обзора активной камеры в вертикальной проекции есть режим Графического редактирования активной камеры.

 

См. подробнее: Область отображения, Скрыть вертикальную проекцию

 

Настройка интерфейса

 

Вы можете настроить видимость кнопок на Панели инструментов, собственные клавиатурные комбинации для всех пунктов меню, реакцию на поворот колесика мыши, чувствительность привязок. Все текстовые ресурсы (заголовки, сообщения, заголовки таблиц и строк в отчетах) хранятся в текстовых файлах с расширением *.lng и могут быть изменены.

 

Планы

 

В проекте может быть до 10 планов. Планы могут соответствовать разнесенным участкам объекта видеонаблюдения. В отчете PDF можно печатать чертежи планов отдельно.

 

См. подробнее: Планы

 

Слои

 

Построения, камеры и 3D модели можно распределять по слоям чертежа. Можно управлять активностью, видимостью, цветом, высотой и другими параметрами каждого слоя. При экспорте чертежа, слои экспортируются в слои файлов форматов AutoCAD *.dxf и *.dwg.

 

См. подробнее: Слои

 

Группы камер

 

Камеры можно объединять в группы.  Можно управлять активностью, видимостью, цветом и другими параметрами групп.  В отчете PDF можно печатать чертежи групп по отдельности.

 

См. подробнее: Группы камер

 

Позиции камер

 

Камеры могут содержать "снимки" их параметров и положений - позиции. Можно копировать позиции в камеры и копировать камеры в позиции. Позиции могут отображаться в 2D и 3D также как и камеры. Позиции позволяют моделировать мультисенсорные камеры, предустановки PTZ камер и Fisheye камер. Но этим их использование не ограничивается.

 

См. подробнее: Позиции камер

 

Нумерация камер

 

Имеется специальный инструмент для переименования камер на планах с последовательной нумерацией.

 

См. подробнее: Нумерация камер

 

Фильтр выделенного

 

Инструмент позволяет быстро отфильтровать выделенные объекты и камеры по множеству признаков и их комбинациям: тип построения или 3D модели, модели камер, фокусные расстояния объективов и разрешения камер, слои, типы линий, цвет в 2D и 3D, материалы.

 

Можно отфильтровать только объекты попадающие полностью или частично в заданный диапазон высот.

 

См. подробнее: Фильтр выделенного

 

Импорт линий подложки в формате AutoCAD *.dxf *.dwg в построения VideoCAD

 

Имеется инструмент позволяющий автоматически превращать несложные 2D подложки в формате AutoCAD в трехмерные построения VideoCAD.

 

См. подробнее: Импорт подложки DXF/DWG

 

Управление порядком отображения объектов и камер на плане и в 3D

 

Имеются инструменты, управляющие тем, как пересекающиеся объекты будут заслонять друг друга в 2D и 3D.

 

См. подробнее: Камеры поверх построений, Высокое разрешение сверху, На передний план, На задний план.

 

Объединение построений

 

Отдельные построения можно объединять в более сложные структуры. Можно сливать контура построений.

 

См. подробнее: Объединить в макроэлемент. Слить контур.

 

Расчет длины кабелей

 

Имеется счетчик длины кабелей, генератор кабельного отчета и инструмент прокладки кабеля.

 

См подробнее. Сигнальный кабель, Расчёт длины отрезков, Кабельный отчёт, Прокладка кабеля

 

Расчет электрических параметров кабелей

 

Имеется калькулятор расчета напряжения на камере в зависимости от параметров источника, камеры и кабеля.

 

См подробнее. Кабель питания

 

       Моделирование специальных камер

 

VideoCAD предлагает инструменты для моделирования специальных камер:

 

 

 

Мультисенсорные камеры (включая камеры со связанными сенсорами и матричные мультисенсорные камеры).

 

 

       Расчет зон обнаружения человека, опознавания человека и чтения автомобильного номера

 

Оценка возможности обнаружения человека, опознавания человека и чтения автомобильного номера лишь по значению плотности пикселей является удобной, но неточной.

Номер или лицо человека может просто не попасть в зону обзора по высоте, или попасть под слишком большим углом и задача опознавания человека или чтения номера не будет решена.

В тоже время для обнаружения человека не обязательно попадание в кадр человека целиком, достаточно попадания части тела. Возможный диапазон высот появления автомобильного номера не совпадает с диапазоном высот появления лица человека.

Поэтому реальная область опознавания человека будет меньше чем окрашенный регион на проекции зоны обзора, реальная область чтения номера будет смещена относительно окрашенного региона, а реальная область обнаружения человека будет больше чем рассчитанная на основе плотности пикселей.

 

Для исключение этой погрешности VideoCAD предлагает более строгие инструменты, учитывающие ограничение по высоте и предельные углы. Вы можете прочесть о них по ссылкам ниже.

 

 

 

 

Вы можете применять эти инструменты при необходимости более точного результата.

 

       Физически точное моделирование функционала камер

 

VideoCAD предлагает уникальные инструменты для физически точного моделирования внутреннего функционала видеокамер.

 

Эффективное использование инструментов моделирования требует достаточного понимания устройства видеокамеры. Некоторые параметры, требуемые для точного моделирования, отсутствуют в спецификациях производителей или их значения в спецификациях завышены и неоднозначны. Поэтому эти параметры придется получать или проверять экспериментально.

 

В сложившейся практике проектирования такое моделирование не является обязательным.  Однако, данные инструменты позволяют повысить точность проекта, моделировать задачи, не поддающиеся моделированию в других программах проектирования.

Инструменты позволяют квалифицированному проектировщику эффективно применить и продемонстрировать свою квалификацию, убедительно обосновывать свои решения, создавать проекты и коммерческие предложения, превосходящие продукты конкурентов.  

 

Инструменты моделирования детально описаны в справочной системе:

 

 

 

 

 

 

 

 

 

 

 

 

 

Смотрите также: Общие сведения о VideoCAD Professional, Примеры работы с VideoCAD, Быстродействие и системные требования